Pre-commit view suggestions

robwall
Posts: 1
Joined: Fri Feb 16, 2007 12:25 am
Contact:

Pre-commit view suggestions

Postby robwall » Fri Feb 16, 2007 1:23 am

[background] I have been using tortoise and Eclipse on NT for 2 years with no problem. Recently I decided to try moving to an iMac, but could not find a decent generic SVN client which is how I came upon subversive (it works great inside Eclipse on either OSX or NT). The OSX fonts suck so badly that I am back to running Eclipse inside XP inside parallels on the iMac (parallels is another very good product).

[problem] So now I have a choice of running subversive, or tortoise or both. I tried both, but the first time I did a commit from tortoise eclipse showed my whole sandbox as unknown files (even though the .svn directories were there). Until I get time to figure this out I am back to using tortoise.

[reaons to change back to subversive] As I see it the main reason for making the effort to change back to subversive would be that it *does* support move class refactorings. This is important if, like me you are addicted to seeing your own checkin comment history (why the F#$ did I do that?), even across class renames/moves.

[FEATURE REQUEST] The other thing that would swing me back is a better pre-commit view: This is essential for the 'code review' step (peer or self!). I have found we find as many bugs in code review as we do with unit tests! I would like:

* A live list view of all changed files. (not unexpanded tree view like you can get now)
* The ability to double click on a file and see a diff view (with character by character coloured diff in a line, like tortoise diff does).
* The ability to see diffs from ALL files in a single window (wincvs used to let you see raw diff output coloured red and blue). This is very useful if you have made one very small change to 50 files, and want to double check.

[sycophantic bit] subversive is the best e plugin I have used, the way it integrates is very slick.

awilkins
Posts: 22
Joined: Tue Feb 13, 2007 7:22 pm

Version incompatibility in working copies.

Postby awilkins » Fri Feb 16, 2007 8:25 am

Your problem with TSVN is down to the issue mentioned in this thread.

http://forums.polarion.org/viewtopic.php?t=1125

The same will effect any 1.4 client. You can use the 1.1 RC5 version of Subversive if you really want the two to coexist. Alas, there is no RC build of FastTrack compatible with 1.1, so if you use that, your other option is to downgrade to a version of TSVN based on SVN 1.3 libraries.


Return to “Polarion Subversive - Eclipse Client for SVN”

Who is online

Users browsing this forum: No registered users and 9 guests