Page 1 of 1

Not working if Subversive 1.0.0.MS12 is also installed

Posted: Wed May 17, 2006 10:30 am
by tuomas_kiviaho
Even the send error dialog broke down under me, so here we go...

Report ID-JYEC1

Version: 1.0.0.MS12

From: Tuomas Kiviaho

User comment:
[empty]

Plug-in ID: org.polarion.team.svn.core.svnnature

java.lang.NoClassDefFoundError: org/polarion/team/svn/core/operation/common/IActionOperation
java.lang.NoClassDefFoundError: org/polarion/team/svn/core/operation/common/IActionOperation
at java.lang.Class.getDeclaredConstructors0(Native Method)
at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
at java.lang.Class.getConstructor0(Unknown Source)
at java.lang.Class.newInstance0(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:157)
at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:759)
at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
at org.polarion.team.svn.ui.extension.ExtensionsManager.loadExtensions(ExtensionsManager.java:219)
at org.polarion.team.svn.ui.extension.ExtensionsManager.loadUIExtensions(ExtensionsManager.java:208)
at org.polarion.team.svn.ui.extension.ExtensionsManager.loadUIExtension(ExtensionsManager.java:203)
at org.polarion.team.svn.ui.extension.ExtensionsManager.<init>(ExtensionsManager.java:196)
at org.polarion.team.svn.ui.extension.ExtensionsManager.getInstance(ExtensionsManager.java:73)
at org.polarion.team.svn.ui.debugmail.Reporter.sendReport(Reporter.java:45)
at org.polarion.team.svn.ui.operation.UILoggedOperation$3.runImpl(UILoggedOperation.java:173)
at org.polarion.team.svn.core.operation.AbstractActionOperation.run(AbstractActionOperation.java:72)
at org.polarion.team.svn.core.operation.LoggedOperation.run(LoggedOperation.java:52)
at org.polarion.team.svn.core.utility.MonitorUtility.doTask(MonitorUtility.java:82)
at org.polarion.team.svn.ui.utility.DefaultCancellableOperationWrapper.run(DefaultCancellableOperationWrapper.java:72)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:113)

JVM Properties:
{java.vendor=Sun Microsystems Inc., org.osgi.supports.framework.extension=true, sun.management.compiler=HotSpot Client Compiler, osgi.framework.beginningstartlevel=1, os.name=Windows XP, sun.boot.class.path=C:\Program Files\Java\jdk1.5.0_06\jre\lib\rt.jar;C:\Program Files\Java\jdk1.5.0_06\jre\lib\i18n.jar;C:\Program Files\Java\jdk1.5.0_06\jre\lib\sunrsasign.jar;C:\Program Files\Java\jdk1.5.0_06\jre\lib\jsse.jar;C:\Program Files\Java\jdk1.5.0_06\jre\lib\jce.jar;C:\Program Files\Java\jdk1.5.0_06\jre\lib\charsets.jar;C:\Program Files\Java\jdk1.5.0_06\jre\classes, osgi.ws=win32, sun.desktop=windows, java.vm.specification.vendor=Sun Microsystems Inc., java.runtime.version=1.5.0_06-b05, osgi.instance.area=file:/C:/Documents and Settings/kivtuo.EDEC/workspaces/esms/, user.name=kivtuo, org.osgi.framework.system.packages=javax.accessibility,javax.activity,javax.crypto,javax.crypto.interfaces,javax.crypto.spec,javax.imageio,javax.imageio.event,javax.imageio.metadata,javax.imageio.plugins.bmp,javax.imageio.plugins.jpeg,javax.imageio.spi,javax.imageio.stream,javax.management,javax.management.loading,javax.management.modelmbean,javax.management.monitor,javax.management.openmbean,javax.management.relation,javax.management.remote,javax.management.remote.rmi,javax.management.timer,javax.naming,javax.naming.directory,javax.naming.event,javax.naming.ldap,javax.naming.spi,javax.net,javax.net.ssl,javax.print,javax.print.attribute,javax.print.attribute.standard,javax.print.event,javax.rmi,javax.rmi.CORBA,javax.rmi.ssl,javax.security.auth,javax.security.auth.callback,javax.security.auth.kerberos,javax.security.auth.login,javax.security.auth.spi,javax.security.auth.x500,javax.security.cert,javax.security.sasl,javax.sound.midi,javax.sound.midi.spi,javax.sound.sampled,javax.sound.sampled.spi,javax.sql,javax.sql.rowset,javax.sql.rowset.serial,javax.sql.rowset.spi,javax.swing,javax.swing.border,javax.swing.colorchooser,javax.swing.event,javax.swing.filechooser,javax.swing.plaf,javax.swing.plaf.basic,javax.swing.plaf.metal,javax.swing.plaf.multi,javax.swing.plaf.synth,javax.swing.table,javax.swing.text,javax.swing.text.html,javax.swing.text.html.parser,javax.swing.text.rtf,javax.swing.tree,javax.swing.undo,javax.transaction,javax.transaction.xa,javax.xml,javax.xml.datatype,javax.xml.namespace,javax.xml.parsers,javax.xml.transform,javax.xml.transform.dom,javax.xml.transform.sax,javax.xml.transform.stream,javax.xml.validation,javax.xml.xpath,org.ietf.jgss,org.omg.CORBA,org.omg.CORBA_2_3,org.omg.CORBA_2_3.portable,org.omg.CORBA.DynAnyPackage,org.omg.CORBA.ORBPackage,org.omg.CORBA.portable,org.omg.CORBA.TypeCodePackage,org.omg.CosNaming,org.omg.CosNaming.NamingContextExtPackage,org.omg.CosNaming.NamingContextPackage,org.omg.Dynamic,org.omg.DynamicAny,org.omg.DynamicAny.DynAnyFactoryPackage,org.omg.DynamicAny.DynAnyPackage,org.omg.IOP,org.omg.IOP.CodecFactoryPackage,org.omg.IOP.CodecPackage,org.omg.Messaging,org.omg.PortableInterceptor,org.omg.PortableInterceptor.ORBInitInfoPackage,org.omg.PortableServer,org.omg.PortableServer.CurrentPackage,org.omg.PortableServer.POAManagerPackage,org.omg.PortableServer.POAPackage,org.omg.PortableServer.portable,org.omg.PortableServer.ServantLocatorPackage,org.omg.SendingContext,org.omg.stub.java.rmi,org.w3c.dom,org.w3c.dom.bootstrap,org.w3c.dom.events,org.w3c.dom.ls,org.xml.sax,org.xml.sax.ext,org.xml.sax.helpers, org.osgi.framework.language=fi, user.language=fi, org.osgi.framework.processor=x86, osgi.syspath=c:\Program Files\eclipse-SDK-3.2RC3-win32\eclipse\plugins, sun.boot.library.path=C:\Program Files\Java\jdk1.5.0_06\jre\bin, osgi.manifest.cache=C:\Program Files\eclipse-SDK-3.2RC3-win32\eclipse\configuration\org.eclipse.osgi\manifests, eof=eof, org.osgi.framework.bootdelegation=*, java.version=1.5.0_06, org.osgi.framework.os.name=WindowsXP, user.timezone=Europe/Helsinki, sun.arch.data.model=32, osgi.bundles=org.eclipse.equinox.common@2:start, org.eclipse.update.configurator@3:start, org.eclipse.core.runtime@start, java.endorsed.dirs=C:\Program Files\Java\jdk1.5.0_06\jre\lib\endorsed, sun.cpu.isalist=pentium_pro+mmx pentium_pro pentium+mmx pentium i486 i386 i86, sun.jnu.encoding=Cp1252, file.encoding.pkg=sun.io, org.osgi.framework.vendor=Eclipse, file.separator=\, java.specification.name=Java Platform API Specification, java.class.version=49.0, user.country=FI, java.home=C:\Program Files\Java\jdk1.5.0_06\jre, osgi.os=win32, eclipse.commands=-os win32 -ws win32 -arch x86 -launcher C:\Program Files\eclipse-SDK-3.2RC3-win32\eclipse\eclipse.exe -name Eclipse -showsplash 600 -exitdata c98_58 -clean -data C:\Documents and Settings\kivtuo.EDEC\workspaces\esms -vm C:\WINDOWS\system32\javaw.exe , java.vm.info=mixed mode, osgi.splashLocation=c:\Program Files\eclipse-SDK-3.2RC3-win32\eclipse\plugins\org.eclipse.platform_3.2.0.v20060505\splash.bmp, os.version=5.1, osgi.arch=x86, path.separator=;, java.vm.version=1.5.0_06-b05, user.variant=, osgi.framework.shape=jar, osgi.instance.area.default=file:/C:/Documents and Settings/kivtuo.EDEC/workspace/, java.awt.printerjob=sun.awt.windows.WPrinterJob, sun.io.unicode.encoding=UnicodeLittle, org.osgi.framework.version=1.3.0, awt.toolkit=sun.awt.windows.WToolkit, osgi.install.area=file:/C:/Program Files/eclipse-SDK-3.2RC3-win32/eclipse/, osgi.framework=file:/c:/Program Files/eclipse-SDK-3.2RC3-win32/eclipse/plugins/org.eclipse.osgi_3.2.0.v20060505.jar, user.home=C:\Documents and Settings\kivtuo.EDEC, osgi.bundlestore=C:\Program Files\eclipse-SDK-3.2RC3-win32\eclipse\configuration\org.eclipse.osgi\bundles, osgi.splashPath=platform:/base/plugins/org.eclipse.platform, osgi.nl=fi_FI, java.specification.vendor=Sun Microsystems Inc., java.library.path=C:\WINDOWS\system32;.;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\ATI Technologies\ATI Control Panel;C:\Program Files\HPQ\IAM\bin;C:\Program Files\Firebird\Firebird_1_5\bin;C:\Program Files\Subversion\bin;c:\Program Files\putty;C:\Program Files\jadnt;c:\cygwin/bin;C:\Program Files\maven-2.0.4/bin;C:\Program Files\eclipse\plugins\org.apache.ant_1.6.5/bin;C:\Program Files\QuickTime Alternative\QTSystem\, java.vendor.url=http://java.sun.com/, org.osgi.framework.os.version=5.1, eclipse.startTime=1147860551982, java.vm.vendor=Sun Microsystems Inc., java.runtime.name=Java(TM) 2 Runtime Environment, Standard Edition, java.class.path=C:\Program Files\eclipse-SDK-3.2RC3-win32\eclipse\startup.jar, eclipse.vm=C:\WINDOWS\system32\javaw.exe, java.vm.specification.name=Java Virtual Machine Specification, java.vm.specification.version=1.0, sun.cpu.endian=little, sun.os.patch.level=Service Pack 2, java.io.tmpdir=C:\DOCUME~1\KIVTUO~1.EDE\LOCALS~1\Temp\, java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi, eclipse.product=org.eclipse.sdk.ide, os.arch=x86, java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment, java.ext.dirs=C:\Program Files\Java\jdk1.5.0_06\jre\lib\ext, user.dir=C:\Program Files\eclipse-SDK-3.2RC3-win32\eclipse, osgi.clean=true, line.separator=
, java.vm.name=Java HotSpot(TM) Client VM, eclipse.ee.install.verify=false, file.encoding=Cp1252, osgi.framework.version=3.2.0.v20060505, eclipse.buildId=I20060505-1306, eclipse.vmargs=-Xmx512M -Xms256M -jar C:\Program Files\eclipse-SDK-3.2RC3-win32\eclipse\startup.jar , java.specification.version=1.5, org.osgi.framework.executionenvironment=OSGi/Minimum-1.0,OSGi/Minimum-1.1,JRE-1.1,J2SE-1.2,J2SE-1.3,J2SE-1.4,J2SE-1.5, osgi.logfile=C:\Documents and Settings\kivtuo.EDEC\workspaces\esms\.metadata\.log, osgi.configuration.area=file:/C:/Program Files/eclipse-SDK-3.2RC3-win32/eclipse/configuration/}

Re: Not working if Subversive 1.0.0.MS12 is also installed

Posted: Fri May 19, 2006 11:23 am
by JiriWalek
FastTrack 0.9.0 depends on the bundled Subversive M9, you have to uninstall previous version of Subversive before instaling FastTrack.

We do not plan to publish FastTrack service releases with new version of Subversive.
Instead we do plan to provide stable integration builds of FastTrack 1.0 soon. This version would be build against new up-to-date Subversive Milestone build and users would be able give us the feedback to new features like:
* project administration (defining categories, timepoints,...)
* query builder
* workitem history view
* ...

0.9.0 not installable

Posted: Fri May 19, 2006 12:39 pm
by hefter
Hi

I'am using Eclipse 3.1.2

svn has not been installed before.

I installed 0.9.0 by the "local update side" zip.

I get, when I try to access any of your functionalities:
[code]
java.lang.ClassNotFoundException: com.polarion.polclipse.internal.ui.perspective.i
at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:405)
at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:350)
at org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(AbstractClassLoader.java:78)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:275)
at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1248)
at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:152)
at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:142)
at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:129)
at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:48)
at org.eclipse.ui.internal.WorkbenchPlugin$1.run(WorkbenchPlugin.java:240)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
at org.eclipse.ui.internal.WorkbenchPlugin.createExtension(WorkbenchPlugin.java:236)
at org.eclipse.ui.internal.registry.ViewDescriptor.createView(ViewDescriptor.java:99)
at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:267)
at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:180)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:552)
at org.eclipse.ui.internal.Perspective.showView(Perspective.java:1655)
at org.eclipse.ui.internal.WorkbenchPage.busyShowView(WorkbenchPage.java:937)
at org.eclipse.ui.internal.WorkbenchPage.access$12(WorkbenchPage.java:920)
at org.eclipse.ui.internal.WorkbenchPage$13.run(WorkbenchPage.java:3199)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage.java:3196)
at org.eclipse.ui.internal.WorkbenchPage.showView(WorkbenchPage.java:3174)
at org.eclipse.ui.handlers.ShowViewHandler.openView(ShowViewHandler.java:146)
at org.eclipse.ui.handlers.ShowViewHandler.openOther(ShowViewHandler.java:102)
at org.eclipse.ui.handlers.ShowViewHandler.execute(ShowViewHandler.java:70)
at org.eclipse.ui.internal.ShowViewMenu$3.run(ShowViewMenu.java:113)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:996)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:538)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:488)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:400)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3125)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2758)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1699)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:367)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)
[code]
------------


And I got
[code]
Network connection problems encountered during search.
Unable to access "http://www.polarion.org/projects/fasttrack/download/update-site/".
Unable to access site: "http://www.polarion.org/projects/fasttrack/download/update-site/" [Server returned HTTP response code: "403 Forbidden" for URL: http://www.polarion.org/projects/fasttr ... date-site/.]
Unable to access site: "http://www.polarion.org/projects/fasttrack/download/update-site/" [Server returned HTTP response code: "403 Forbidden" for URL: http://www.polarion.org/projects/fasttr ... date-site/.][/code]
[code]
error on update.

Frank[/code]

Posted: Wed May 24, 2006 8:28 am
by zachara
Hello,
please could you try to install it into a new eclipse instalation.
If this problem still remain, please send us your log file from workspace/.metadata/log.