Subversive doesn't recognize a svn-project

mortensi
Posts: 2
Joined: Thu Oct 26, 2006 12:39 pm

Subversive doesn't recognize a svn-project

Postby mortensi » Thu Oct 26, 2006 12:59 pm

Hi

[Background] I had created a Java-project and put it into Subversion. Everything worked fine with Subversive. However, I wanted to change my src-catalog from src/main/java to just src/

[What I did] I closed the project in Eclipse and used Tortoise to SVN Move all the files from one directory to another. I then used Tortoise to commit the changes. Everything seemed fine in Subversion and Tortoise.

[What happened] I reopened my project in Eclipse, but Subversive did not know of any connection to Subversion, even though the .svn-catalogs were there. It only displayed a question-mark at the upper right corner of the project-symbol. The context-menu didn't allow me to do anything except "synchronize", "add to source control" and a few other options. No possibility to "disconnect".

[Workaround] It only worked when I deleted the files and checked out from Subversion again.

[Question] Is this how it is meant to be?

Thanks for any reply
Morten Simonsen

fredjean
Posts: 1
Joined: Thu Oct 26, 2006 6:47 pm

M7 Seems to have Amnesia

Postby fredjean » Thu Oct 26, 2006 6:51 pm

I am experiencing similar problems with M7 on a project that used to work well. I have reverted to M5 for now.

ivinnykov
Posts: 473
Joined: Tue Jan 03, 2006 11:57 am
Location: Kharkiv, Ukraine

Postby ivinnykov » Wed Nov 15, 2006 2:34 pm

Dear Morten,

Project, which is controlled by Subversive it is not only project content and SVN meta-information, but also project meta-information in Eclipse. So if you performed some critical structural changes it is expected that these changes are not reflected in the Subversive. Only SVN-related changes, like commits outside Eclipse, etc. are reflected if you restart Subversive or perform project refresh. Note that actions, which you did from Tortoise you can make from Subversive directly to avoid such problems.

Also I suggest you to update to the latest version of the Subversive, which contains some important fixes.
Best regards,
Igor Vinnykov
Polarion Team

zartc
Posts: 6
Joined: Thu Nov 23, 2006 11:11 am

Re: Subversive doesn't recognize a svn-project

Postby zartc » Tue Jan 16, 2007 5:19 pm

close and reopen the project under eclipse (just closing, not deleting). It works for me, it might works for you to.

raudi
Posts: 5
Joined: Mon Oct 02, 2006 8:20 am

is it because of subversion 1.4.1???

Postby raudi » Wed Jan 17, 2007 10:15 am

i had a similar problem on one of my co-workers machine he uses a newer version of tortoise (i think 1.4.0).

my explanation for this is that tortoise> 1.4 is built against subversion 1.4.x and as the tortoise website states under "Compatibility Concerns":

"Subversion 1.4 uses a new format for the working copy. The update is done automatically, you won't even notice it. But once the working copy has been updated, you won't be able to access it with clients linked to older versions of the Subversion library"

so i suspect that subversive is not working with the new file format ("8" in .svn/format)

can somebody confirm this?
is there a solution to work with 1.4 working copies with subversive?

zartc
Posts: 6
Joined: Thu Nov 23, 2006 11:11 am

Postby zartc » Wed Jan 17, 2007 1:56 pm

Subversive 1.1.0 use the subversion 1.4 working copy format as far as I know. I am working on a project where I use either subversive under eclipse and also tortoise on the same working copy, and it works.

ZartC.

raudi
Posts: 5
Joined: Mon Oct 02, 2006 8:20 am

update to new working copy format

Postby raudi » Fri Jan 19, 2007 2:01 pm

zartc: could you please make sure if your ".svn/format" files contain the number 8 (and not 4)?
which tortoise do you use?

i would *LOVE* to move to the 1.4 tortoise
but i don't want to have the trouble again that my eclipse/subversive can not access the new projects and i have to work parallel with subversive and subclipse (which is sometimes a drag (e.g. share project: wich SVN is subversive???))

as far as i can see subversive does not update existing projects to the new format (which tortoise obviously does automatically on some commands)

thanks a lot
patrick

ctaggart
Posts: 2
Joined: Mon Feb 19, 2007 8:07 pm

Postby ctaggart » Mon Feb 19, 2007 8:10 pm

I'm having the same issue. My .svn/format files contain 8. Is that a TortoiseSVN bug? I'm running the latest TortoiseSVN client.

TortoiseSVN 1.4.3, Build 8645 - 32 Bit , 2007/02/04 09:40:57
Subversion 1.4.3,
apr 0.9.12
apr-iconv 0.9.7
apr-utils 0.9.12
berkeley db 4.4.20
neon 0.26.3
OpenSSL 0.9.8d 28 Sep 2006
zlib 1.2.3

Cameron

ctaggart
Posts: 2
Joined: Mon Feb 19, 2007 8:07 pm

Postby ctaggart » Mon Feb 19, 2007 8:28 pm

Works fine when I switch the SVN Client that Subversive uses from JavaSVN 1.0.4 to SVNKit 1.1.0. BTW, I'm using Subversive 1.1.0.RC5 with Eclipse 3.3M5 and Sun jdk1.6.0.

cheers,
Cameron


Return to “Polarion Subversive - Eclipse Client for SVN”

Who is online

Users browsing this forum: No registered users and 7 guests