Commit fails without error message

dbranson
Posts: 3
Joined: Sat Jan 12, 2008 3:58 pm

Commit fails without error message

Postby dbranson » Sat Jan 12, 2008 4:16 pm

All,

Hopefully this is just a newbie problem...

I've converted my linux-hosted cvs repository to Subversion using the command 'cvs2svn -s svnroot cvsroot'. Everything looked good, so I began using the Subversive eclipse plugin (on my Windows dev box), checked some projects out, looked around, everything looked clean.

The url I'm using is svn+ssh://dev1/home/common/repositories/svnroot

Next I made a few code changes. Now I'd like to commit. So, Team... Synchronize with Repository...Commit All Outgoing Changes. I entered a comment, clicked OK, and a dialog comes up very briefly saying, "Operation in progress..." then goes away.

In the team synch view, all the changed files still show as changes. If I check out the project on another machine, the new changes are not there.

So my question is, did the commit fail without any message, or is there something I need to do after commit in order to send the changes to the repository?

Thanks,
Don

dbranson
Posts: 3
Joined: Sat Jan 12, 2008 3:58 pm

Follow with more info

Postby dbranson » Sat Jan 12, 2008 11:45 pm

Here's what the output from the failed commit looks like:

Code: Select all

*** Commit
svn commit "C:\java\workspace\SVN - DonsProxy\build.xml" -m "test" --username "don"
   M C:/java/workspace/SVN - DonsProxy/build.xml
     Transmitting file data: C:/java/workspace/SVN - DonsProxy/build.xml
Committed revision -1
*** Ok (took 00:00.250)


There's nothing here that clearly indicates what the failure is, that's the mystifying part.

Thoughts anyone?

dbranson
Posts: 3
Joined: Sat Jan 12, 2008 3:58 pm

Fixed

Postby dbranson » Sun Jan 13, 2008 1:29 am

Okay, here's the error message that lets you know of the failure:

Code: Select all

Committed revision -1


Here's what a correct one looks like:

Code: Select all

Committed revision 841


What was the problem? The user did not have access rights to write in certain directories, because I had run cvs2svn as root. A recursive chmod of the svn repo might have fixed it, but I don't know. I blew away the svn repo, logged in as a non-root user, and re-ran the export. This fixed the problem.

I tried the same scenario in CVS, and CVS overwrites the file in the repository, and therefore works just fine.

I think every failure should give some feedback to the user with clues about what the problem might be.


Return to “Polarion Subversive - Eclipse Client for SVN”

Who is online

Users browsing this forum: No registered users and 2 guests