Problems with class import when using Subversive API

merche
Posts: 3
Joined: Wed Sep 26, 2007 8:01 am
Location: germany

Problems with class import when using Subversive API

Postby merche » Wed Sep 26, 2007 11:08 am

I have a custom implementation of org.polarion.team.svn.core.extension.crashrecovery.IResolutionHelper to modify the standard behavior of org.polarion.team.svn.ui.crashrecovery.DiscardedLocationHelper.

After an upgrade from Subversive 1.1.3 to 1.1.7 the package org.polarion.team.svn.core can't be found from my classes in the Eclipse workspace anymore.

I figured out that this is reasoned by the fact that the org.polarion.team.svn.core plugin is shipped as a jar which itself contains a jar (SVNTeamCore.jar). Eclipse can't access the jar inside the jar. I fixed it by simply extracting org.polarion.team.svn.core_1.1.7.jar to the plugins folder. I did the same for org.polarion.team.svn.ui to be able to access its classes.

Would it be possible to fix the plugin export for future releases?

Best regards,

Matthias Erche

Alexander Gurov
Posts: 205
Joined: Fri Mar 17, 2006 11:33 am

Postby Alexander Gurov » Wed Sep 26, 2007 1:32 pm

Dear Matthias,

thank you for reporting the problem and for your investigation of the problem reason. It will be fixed in the Subversive version 1.1.8.
Best regards,
Alexander Gurov
Subversive Team


Return to “Polarion Subversive - Eclipse Client for SVN”

Who is online

Users browsing this forum: No registered users and 4 guests