Page 1 of 1

The old refactor + compare problem...

Posted: Tue Aug 07, 2007 2:10 pm
by NimdaCinatas
Hi users, admins, moderators, ...

some month ago I switched back to the subclipse plugin because nobody seemed to be able to solve the issues mentioned in this thread.

Today I thought I could try subversive one more time so I installed it via the update site for eclipse 3.2 (I'm using 3.2.2). Most subversive features are incredible nice - but the issues mentioned above are still there.

I tried the following with SVNkit 1.1.4 and JavaSVN 1.0.4:

1. searched the same refactored files I used when opening the old case
2. Rightclick -> compare-with -> Revision -> <old revision from before refactoring>

...and always the error "Subversive: '0x00400103: Compare with Revision' operation finished with error: svn: File not found: revision <old_rev>, path '<new_path>' " occured.

So the error is still the same as last year (time of call opened).

So again the question last asked in April (and not answered by anyone):

"Is anybody working on this?"

If not, "will anybody work on this?"

BTW:
- we've no http access to our svn repo (the first call was closed because "works for http access" or something)
- Eclipse 3.2.1
- svn 1.4.3
- svn team provider (subversive) 1.1.5
- svnkit 1.1.4 and
- javasvn 1.0.4

...and "competition" (subclipse) works great regarding this issue - no problems here.

Many thanks in advance,
NC

Posted: Wed Nov 28, 2007 6:10 pm
by akira
Same problem here... no reply on the mailing lists. It's the old pretend there is no problem ;).

Posted: Fri Nov 30, 2007 1:21 pm
by NimdaCinatas
I just installed eclipse 3.3 with subversive 0.7.0 (from official eclipse project site).

Will test the problem again with this new configuration at weekend and report back at monday.

NC