Compiling subversive from src (eclipse-301.jar dependency)

markus
Posts: 1
Joined: Mon Jul 23, 2007 10:31 am

Compiling subversive from src (eclipse-301.jar dependency)

Postby markus » Mon Jul 23, 2007 12:01 pm

Dear All,

I'm trying to apply the patch for the Subclipse to Subversive migration issue which has been mentioned in http://forums.polarion.org/viewtopic.php?t=2686&highlight=subclipse+workspace.

However, when trying to compile the source code for org.polarion.team.svn.core, there is a unsatified dependency to eclipse-301.jar. Where can I find and download this file in order to add it to my local Maven repository and make Subversive compile?

Kind regards,

Markus

Alexander Gurov
Posts: 205
Joined: Fri Mar 17, 2006 11:33 am

Postby Alexander Gurov » Thu Jul 26, 2007 2:13 pm

Dear Marcus,

The Subversive project does not contain direct dependencies on Eclipse IDE jar's. So, I think the problem relates to misconfiguration of your build environment. In order to check this please try to checkout the Subversive sources from http://svn.polarion.org/repos/community/Subversive/trunk using Eclipse IDE, then run pop-up menu "PDE Tools->Build Site" action over the org.polarion.team.svn.update-site/site.xml file.
In that case Eclipse should make update site from the Subversive sources.
Best regards,
Alexander Gurov
Subversive Team


Return to “Polarion Subversive - Eclipse Client for SVN”

Who is online

Users browsing this forum: No registered users and 2 guests