Subversive dependency with JDT

benza
Posts: 5
Joined: Thu Mar 08, 2007 5:10 pm

Subversive dependency with JDT

Postby benza » Thu Mar 08, 2007 5:16 pm

Hi,

How come Subversive is dependent on JDT ?

It appears that org.polarion.team.svn.core is dependent on org.eclipse jdt.core

moreover, the only class using it is FileUtility. I think that this dependency is problematic since not all Subversive users use JDT or want to install JDT just to use Subversive.

Is it possible to disconnect the dependency and implement the needed functionality internally ?

benza
Posts: 5
Joined: Thu Mar 08, 2007 5:10 pm

Any reply would be highly appreciated. 10X

Postby benza » Sun Mar 11, 2007 11:59 am

Any reply would be highly appreciated

Alexander Gurov
Posts: 205
Joined: Fri Mar 17, 2006 11:33 am

Postby Alexander Gurov » Tue Mar 13, 2007 11:54 am

Dear benza,

Thank you for your tips.

We posted this task to our tracker and we will solve this problem after Subversive 1.1.0 is released.
Best regards,
Alexander Gurov
Subversive Team

benza
Posts: 5
Joined: Thu Mar 08, 2007 5:10 pm

10X

Postby benza » Sun Mar 18, 2007 11:57 am

can you please post a message or send a mail when it's fixed so we can test it.

10X

benza
Posts: 5
Joined: Thu Mar 08, 2007 5:10 pm

any updates ?

Postby benza » Sun Mar 25, 2007 3:36 pm

10x

Alexander Gurov
Posts: 205
Joined: Fri Mar 17, 2006 11:33 am

Postby Alexander Gurov » Tue Apr 03, 2007 9:39 am

Dear benza,

The Subversive JDT dependency is moved into different plug-in which is connected with an extension point. This change will be available starting from the Subversive version 1.1.1 which will be published at the end of this week.
Best regards,

Alexander Gurov

Subversive Team

benza
Posts: 5
Joined: Thu Mar 08, 2007 5:10 pm

10X for the update

Postby benza » Wed Apr 04, 2007 8:52 pm

and 10X for the quick fix...


Return to “Polarion Subversive - Eclipse Client for SVN”

Who is online

Users browsing this forum: No registered users and 5 guests