Svn+ssh appears to be timing out

selly
Posts: 2
Joined: Wed Feb 07, 2007 6:00 pm

Svn+ssh appears to be timing out

Postby selly » Wed Feb 07, 2007 6:04 pm

First off, thanks for making subversive! And congrats on the acceptance by the Eclipse foundation.

Ok, on to matters of business! I'm (and 2 of my fellow developers) are using subversive on MacBook's. We've had the same problems on the RC and the most recent GA versions:

When we first start Eclipse, we can do all the repository operations: update, commit, compare, synchronize.

After about 1/2 hour or so of coding or other subversion inactivity, if we try to do an update, commit, synchronize, we get stuck with the "Operation in progress" window and the entire system locks up. I can either force-quit Eclipse or wait about 20 minutes then I have to do a cleanup and then can execute my operation.

Are we alone out there with this problem? Is this a problem with JavaSVN or with Subversive or with our config :?:

Thanks,
Selly

selly
Posts: 2
Joined: Wed Feb 07, 2007 6:00 pm

Interesting...

Postby selly » Wed Feb 07, 2007 6:10 pm

I just had an interesting experience. While I was signing up and posting:

Committed revision 634
*** Ok (took 08:51.491)

This was a single java file (1-line change) and it took 8:51 to complete. It wasn't the connection because I'm actively using an ssh-pipe to the same server... :!: :?: :!:

Alexander Gurov
Posts: 205
Joined: Fri Mar 17, 2006 11:33 am

Postby Alexander Gurov » Thu Feb 08, 2007 11:42 am

Dear Selly,

Thank you for information. This problem relates to JavaSVN and it is very hard to reproduce due to dependency from connection settings. We will report the problem to JavaSVN authors. Also as workaround I would propose you to use http/https protocol instead of svn+ssh if it is possible for you.
Best regards,
Alexander Gurov
Subversive Team

Alexander Gurov
Posts: 205
Joined: Fri Mar 17, 2006 11:33 am

Postby Alexander Gurov » Fri Feb 16, 2007 5:14 pm

Hello All,

We checked the problem with the JavaSVN authors. The problem looks like it is related to libapr.so configured to use /dev/random instead /dev/urandom.
More information you can find at:
http://svn.haxx.se/users/archive-2005-09/0235.shtml
Best regards,

Alexander Gurov

Subversive Team


Return to “Polarion Subversive - Eclipse Client for SVN”

Who is online

Users browsing this forum: No registered users and 3 guests