Page 1 of 1

Installation problems

Posted: Sun Oct 04, 2009 9:07 pm
by MarioColuzzi
That's the reason I HATE OPENSOURCE: IT NEVER WORKS!!!

Anyway ...

Downloaded SVNwebClient and installed following the txt file in the zip file.

1) when I modify the web.xml Tomcat reports: FAIL - Application at context path /svnwebclient could not be started

2) a directory was missing in the installation as per the embedded error message: "Message: File "/include/dialog/include/head.jsp" not found" I had to copy the "include" directory into dialog to get the next error message.

Still svnwebclient is still a crap program because it still not working on my end, or should I call NASA?

Re: Installation problems

Posted: Tue Oct 06, 2009 11:49 am
by iburilo
Hello Mario,

What version of Tomcat and SVNWebClient do you use? You can see SVNWebClient version in readme.txt, changes.txt.

Re: Installation problems

Posted: Wed Oct 07, 2009 12:25 pm
by hlacikd
Hello,

we are really sorry to hear that. Could you please provide us with the log from error you are experiencing as well as description of what you are trying to achieve?
We will try to help you.

Thank you and Best Regards,
David Hlacik
Polarion Software Support Specialist
support@polarion.com

Re: Installation problems

Posted: Sat Oct 24, 2009 7:32 pm
by tien1411nd
I have the same problem. In my case, I deploy SVB Web Client as below

Environment: Windows XP SP1, apache-tomcat-6.0.20, WampServer Version 2.0

1) deploy "svnwebclient.war". After that, access URL http://localhost:8080/svnwebclient/ and found many problems.
2) install "libintl-2", "libiconv-2". After that, access URL http://localhost:8080/svnwebclient/ and found a few problems.
3) install "enscript". After that, access URL http://localhost:8080/svnwebclient/ and found a problem at Message box
File /include/dialog/include/head.jsp not found
4) I copy /include/head.jsp to /include/dialog/include/head.jsp. Message box shows:
org.polarion.svnwebclient.SVNWebClientException: org.polarion.svnwebclient.SVNWebClientException: org.tmatesoft.svn.core.SVNAuthenticationException: svn: Credential data unavailable
5) However, after delete /include/dialog/include/head.jsp, I think that the problem at Step 3 will happen, but Message box stills show the problem at step 4
org.polarion.svnwebclient.SVNWebClientException: org.polarion.svnwebclient.SVNWebClientException: org.tmatesoft.svn.core.SVNAuthenticationException: svn: Credential data unavailable

And this is log file at step 3 and step 4

Oct 25, 2009 2:00:20 AM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet jsp threw exception
javax.servlet.ServletException: File "/include/dialog/include/head.jsp" not found
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:319)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:551)
at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:488)
at org.apache.jasper.runtime.JspRuntimeLibrary.include(JspRuntimeLibrary.java:968)
at org.apache.jsp.include.dialog.reportReview_jsp._jspService(reportReview_jsp.java:64)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.polarion.svnwebclient.authorization.impl.BindSessionsFilter.doFilter(BindSessionsFilter.java:48)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.polarion.svnwebclient.web.CharsetFilter.doFilter(CharsetFilter.java:52)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:849)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:454)
at java.lang.Thread.run(Unknown Source)
Oct 25, 2009 2:11:53 AM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet jsp threw exception
org.tmatesoft.svn.core.SVNAuthenticationException: svn: Credential data unavailable
at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:47)
at org.tmatesoft.svn.core.internal.io.dav.DAVUtil.findStartingProperties(DAVUtil.java:124)
at org.tmatesoft.svn.core.internal.io.dav.DAVUtil.getBaselineProperties(DAVUtil.java:197)
at org.tmatesoft.svn.core.internal.io.dav.DAVUtil.getBaselineInfo(DAVUtil.java:160)
at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.fetchRepositoryRoot(DAVConnection.java:77)
at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getRepositoryRoot(DAVRepository.java:115)
at org.polarion.svnwebclient.data.javasvn.DataProvider.getID(DataProvider.java:134)
at org.polarion.svnwebclient.web.InitListener.contextInitialized(InitListener.java:77)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3934)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4429)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:526)
at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:850)
at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:724)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:493)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1206)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:314)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:722)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
at org.apache.catalina.core.StandardService.start(StandardService.java:516)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
at org.apache.catalina.startup.Catalina.start(Catalina.java:583)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)

Best regards,
Nguyen Duc Tien

Re: Installation problems

Posted: Fri Nov 06, 2009 11:17 am
by iburilo
The problem was fixed, I created a corresponding bug in tracker: http://community.polarion.org/polarion/ ... VNWEBC-484.

Re: Installation problems

Posted: Tue Dec 15, 2009 8:20 pm
by 188Computin
I don't have access to the community so can someone just give a short summary of the solution? Or maybe tell me where to sign up for that community account? (Why is it separate from this forum?)

Re: Installation problems

Posted: Thu Dec 17, 2009 4:45 pm
by chyliko
[quote="188Computin"]I don't have access to the community so can someone just give a short summary of the solution? Or maybe tell me where to sign up for that community account? (Why is it separate from this forum?)[/quote]

The details of the fix can be seen when inspecting the repository revision linked to http://community.polarion.org/polarion/ ... VNWEBC-484

In case you do not have an account for the Community server, you are presented with a login screen which features a "Create an account now... " link. Unfortunately the forum account is not shared in the SSO mean with the Community tracker.

As I can see in the mentioned revision, the fix seems to be a single line change:
<jsp:include page="include/head.jsp">
to
<jsp:include page="/include/head.jsp">

in webapp / include / dialog / reportReview.jsp

Re: Installation problems

Posted: Thu Dec 29, 2011 8:18 pm
by chelsea20
MarioColuzzi wrote:That's the reason I HATE OPENSOURCE: IT NEVER WORKS!!!

Anyway ...

Downloaded SVNwebClient and installed following the txt file in the zip file.

1) when I modify the web.xml Tomcat reports: FAIL - Application at context path /svnwebclient could not be started

2) a directory was missing in the installation as per the embedded error message: "Message: File "/include/dialog/include/head.jsp" not found" I had to copy the "include" directory into dialog to get the next error message.

Still svnwebclient is still a crap program because it still not working on my end, or should I call NASA?


Hi MarioColuzzi

I'm new to open source and i 'm also have the same problem, have you found a fix or could you point me in the right direction.
Would be much appreciated.

Regards