log in does not work

Former SVN Browser
Klaus

log in does not work

Postby Klaus » Wed Sep 07, 2005 9:24 am

Hi,

I am using the following:

Apache2
Tomcat 5
SVN 1.2.3 (via webdav)

When I try to login with svnbrowser, then I get a white screen and in the upper left corner is "error page" written.

In access.log from apache is this:

10.1.12.155 - - [07/Sep/2005:11:21:54 +0200] "PROPFIND /svn/prslg3/!svn/vcc/default HTTP/1.1" 401 554 "-" "SVNBrowser 1.0"
10.1.12.155 - klaus [07/Sep/2005:11:21:54 +0200] "PROPFIND /svn/prslg3/!svn/vcc/default HTTP/1.1" 207 403 "-" "SVNBrowser 1.0"
10.1.12.155 - - [07/Sep/2005:11:21:54 +0200] "PROPFIND /svn/prslg3/!svn/bc/84// HTTP/1.1" 401 554 "-" "SVNBrowser 1.0"
10.1.12.155 - klaus [07/Sep/2005:11:21:54 +0200] "PROPFIND /svn/prslg3/!svn/bc/84// HTTP/1.1" 207 4619 "-" "SVNBrowser 1.0"

When I access http://10.1.12.155/svn/prslg3 with the same username and password, then everything works fine.

What is wrong?


Greetings,
Klaus

dobisekm
Posts: 118
Joined: Wed Mar 23, 2005 3:29 pm
Location: Prague, Czech Republic

Postby dobisekm » Mon Sep 19, 2005 9:16 am

Hi Klaus,

it seems that the problem is caused by Tomcat5 - SVNWebBrowser was not developed for it and seems not to work. Try the following fix, it might help:

4) only for Tomcat 5.5.x and more:
a) download JSTL 1.1 (for example http://apache.alkar.net/jakarta/taglibs ... 1.2.tar.gz)
b) unpack files jakarta-taglibs-standard-1.1.2.tar.gz/lib/jstl.jar & standard.jar to folder %PROJECT_ROOT%/WEB-INF/lib
c) remove jstl-1.0.2.jar & standard-1.0.4.jar files from folder %PROJECT_ROOT%/WEB-INF/lib

Best,

Michal, Polarion Team

Francois

Postby Francois » Wed Sep 21, 2005 1:07 pm

The solution above works for me and resolved my login problem.

Now, I still get the "Error Page" when clicking on a revision number in the file history.Could it be related to the same problem (Tomcat 5, Apache 2, Java 1.5 and SVN 1.2.3)?

dobisekm
Posts: 118
Joined: Wed Mar 23, 2005 3:29 pm
Location: Prague, Czech Republic

Postby dobisekm » Wed Sep 21, 2005 2:41 pm

Francois wrote:Now, I still get the "Error Page" when clicking on a revision number in the file history.Could it be related to the same problem (Tomcat 5, Apache 2, Java 1.5 and SVN 1.2.3)?


Does the error page show any stack trace? If not, is there anything in the Tomcat logs?

Michal Dobisek, Polarion Team

Guest

Postby Guest » Wed Sep 21, 2005 4:18 pm

I'm getting these errors in "access.log" in Apache:
/svnrep/!svn/bc/3940/src/calib.c HTTP/1.1" 200 87916
10.0.67.126 - - [21/Sep/2005:11:59:34 -0400] "PROPFIND /svnrep/src/calib.c HTTP/1.1" 207 736
10.0.67.126 - - [21/Sep/2005:11:59:34 -0400] "PROPFIND /svnrep/!svn/vcc/default HTTP/1.1" 207 397
10.0.67.126 - - [21/Sep/2005:11:59:34 -0400] "PROPFIND /svnrep/!svn/bln/3940 HTTP/1.1" 207 454
10.0.67.126 - - [21/Sep/2005:11:59:34 -0400] "REPORT /svnrep/!svn/bc/3940/src/calib.c HTTP/1.1" 200 1688

In Tomcat "stdout_20050920.log"
ERREUR : '\xsl\blame.xsl (Le chemin d'accs spcifi est introuvable)'
ERREUR BLOQUANTE : 'Impossible de compiler la feuille de style'

which mean in english:
Error: "\xsl\blame.xsl ( Specified Path Invalid)
Blocking Error: 'Unable to compile style sheet'

One more detail, i'm running on windows 2000.

Francois

dobisekm
Posts: 118
Joined: Wed Mar 23, 2005 3:29 pm
Location: Prague, Czech Republic

Postby dobisekm » Tue Dec 13, 2005 1:38 pm

Hi Francois,

please try to get the new SVN Web Client release build, it fixes many problems, likely including yours.

Best,

Michal
Polarion Team

ivinnykov
Posts: 473
Joined: Tue Jan 03, 2006 11:57 am
Location: Kharkiv, Ukraine

Postby ivinnykov » Wed Jan 04, 2006 1:30 pm

Hello,

Reported problems are related to previous XSLT-based version. Current 1.0.0 version is significantly reworked in compare with previous one (please see release notes). Current version doen't use XSLT and JSTL and also supports Tomcat 5.5. Please use latest version.
Best regards,
Igor Vinnykov
Polarion Team


Return to “Polarion SVN Web Client”

Who is online

Users browsing this forum: No registered users and 1 guest