SSL and Authentification

Former SVN Browser
Youenn
Posts: 8
Joined: Fri Jun 02, 2006 5:33 pm

SSL and Authentification

Postby Youenn » Mon Jun 19, 2006 7:48 pm

Hello,

i tried to use SSL with SvnWebClient, but now the authentification doesn;t work.

I change the file web.xml on parameter \
ProtocolKeyFile > /etc/apache2/ssl/server.key
ProtocolPassPhrase > correct passwd
BasicAuth > false
BasicRealm > Realm

In /modules.d/41_mod_ssl.default-vhost.conf
I use SSLCertificateKeyFile conf/ssl/server.pem

I tried with and without SSLRequireSSL


And in file /etc/apache2/vhosts.d/00_default_vhost.conf
<VirtualHost *:80>

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/(.*) https://%{SERVER_NAME}/$1 [R,L]

</VirtualHost>

Thanks

Youenn
Posts: 8
Joined: Fri Jun 02, 2006 5:33 pm

Help please

Postby Youenn » Thu Jun 22, 2006 12:39 pm

Can you help me please??

Youenn
Posts: 8
Joined: Fri Jun 02, 2006 5:33 pm

Found

Postby Youenn » Thu Jun 22, 2006 3:25 pm

in web.xml

https and not http

ivinnykov
Posts: 473
Joined: Tue Jan 03, 2006 11:57 am
Location: Kharkiv, Ukraine

Postby ivinnykov » Fri Jun 23, 2006 2:25 pm

Dear Youenn,

As far as I understood problem was resolved. Isn't it? Please let me know. Thank you.
Best regards,
Igor Vinnykov
Polarion Team

Youenn
Posts: 8
Joined: Fri Jun 02, 2006 5:33 pm

Postby Youenn » Wed Jun 28, 2006 5:53 pm

Yes

franc
Posts: 14
Joined: Sat Mar 03, 2007 9:57 am

Re: SSL and Authentification

Postby franc » Mon Sep 27, 2010 11:26 pm

Could someone tell me, how this works?
I don't know which certificate i put into ProtocolKeyFile and which password.
I have a password for my ca-certificate but none for the ssl-encryption.

But with https i get a loop and without i cannot log in.


Return to “Polarion SVN Web Client”

Who is online

Users browsing this forum: No registered users and 2 guests