Page 1 of 1

ParentRepositoryDirectory non-working for root-dir?

Posted: Thu Dec 04, 2008 11:37 am
by axismundi
We have our repos directly under the root URI:
svn://server/repo1
svn://server/repo2

I configured ParentRepositoryDirectory with value "svn://server/"

Using this setup i get only message "Your credentials are not correct. ", both using no login-data (anon-access) and correct credentials.

What is the problem?

Re: ParentRepositoryDirectory non-working for root-dir?

Posted: Thu Dec 04, 2008 2:31 pm
by axismundi
I turned on debug-level and the svn-url is correct:

2008-12-04 15:25:56,416 [http-8080-10] (CredentialsManager.java:86) DEBUG org.polarion.svnwebclient.authorization.impl.CredentialsManager - It's not all
owed to enter, your credentials: username - , password - url - svn://svn/nps

From the same machine I can successfully checkout from the command-line: svn co svn://svn/nps

What please is the problem here?

Re: ParentRepositoryDirectory non-working for root-dir?

Posted: Fri Dec 05, 2008 1:25 pm
by axismundi
I figured out that actually the values for username and password are not passed from the UI, it is cached somewhere!!

Anybody had that phenomenon?

Re: ParentRepositoryDirectory non-working for root-dir?

Posted: Thu Apr 22, 2010 11:38 am
by nutella
Same error here. Funny thing that it worked before... I didn't change any configuration in tomcat or polarion itself...So I'm wondering what is causing this? There were some changes in the hosts and hostnames another administrator made. So probably thre problem lies there.

If you guys have any ideas regarding this problem, any help is welcome :)

cya

Re: ParentRepositoryDirectory non-working for root-dir?

Posted: Wed Apr 28, 2010 6:40 am
by nutella
After a Restart /etc/hosts was overwritten. In my web.xml of the repository I have the url like "svn.myhost.com"

I needed to enter this in /etc/hosts again like:

127.0.0.1 localhost.localdomain localhost svn.myhost.com

and it worked again.