Reports take 5 minutes to load

Description
SteffPoint
Posts: 26
Joined: Wed Mar 07, 2018 1:06 pm

Reports take 5 minutes to load

Postby SteffPoint » Wed May 23, 2018 8:33 am

I have the issue that reports are loading literally for ages. By looking into the developer-tools of webbrowser I notice, that within the first 300.000 ms (5 minutes) almost nothing happens.

Especially when looking at the pie chart one might see, that "Idle" takes most of the time - but I don't know what that means.

Fun fact: We got a copy of exactly the same "polarion farm" on another server - and even though the hardware of the other server is way worse, it loads there within a few seconds. That makes me thinking if maybe licenses can cause such a problem - but I don't know if it's the right path to research on. That's why I am looking forward for expert help in this forum.


Any help, ideas and tricks are highly appreciated :)
Last edited by SteffPoint on Wed Jun 13, 2018 11:16 am, edited 1 time in total.

Jürgen
Posts: 38
Joined: Tue Sep 12, 2017 1:02 pm

Re: Reports take 5 minutes to load

Postby Jürgen » Tue Jun 12, 2018 12:28 pm

ok, here is an idea: I have experienced, that wiki pages with a lot of work items load a lot of faster when the user has global admin rights, probably because for them the access rights are not (or differently) checked during access.

I think when the browser is idle that just means that the server is computing heavily and the browser does not get a response for some time, resulting in an idle browser. If you have access to the server you could check with the task manager if load is heavy when you create the report. Or you could check in the log files if there is a hint that maybe something is wrong in the background.

Basically there are a lot of reasons possible, from a bad network connection to heavy load on the server.

SteffPoint
Posts: 26
Joined: Wed Mar 07, 2018 1:06 pm

Re: Reports take 5 minutes to load

Postby SteffPoint » Tue Jun 12, 2018 1:03 pm

You are right Jürgen, it really has some issue with the permission level, because with global admin rights loading times are pretty short and reports load within a few seconds.

A closer analysis of the server and it's performance with the task manager shows, that the server and it's components easily can handle the tasks. Also I couldn't find any errors.

So I bet it must be any problem resulting from licenses, but got no clue how to fix it yet.

Jürgen
Posts: 38
Joined: Tue Sep 12, 2017 1:02 pm

Re: Reports take 5 minutes to load

Postby Jürgen » Wed Jun 13, 2018 10:54 am

I am not sure if this can be fixed by you. When I talked to the support team in my case, they explained that the global admins have kind of "shortcut" because they are allowed to see everything.

For normal users Polarion checks everything, and depending on your usecase, for example it also not only checks the access rights for a work item, but also for all the linked items of this work item. So if you have a bigger number of work items with even bigger number of linked work items it might happen, that thousands of objects are checked for your report.

For us the problem occurs mainly for big trace tables (we have trace tables with 4 or 5 levels in one report).

It might help to split a report into several parts. We observed, that building a report for one document with 300 work items takes much longer than making a report for 3 documents with 100 work items, because there seems to be an exponential growth for the duration depending on the number of work items. So maybe an idea could be to split the report into parts.


Return to “Polarion Application Lifecycle Management (ALM)”

Who is online

Users browsing this forum: No registered users and 7 guests