can't update Polarion

Description
ValeV
Posts: 2
Joined: Tue Sep 05, 2017 1:07 pm

can't update Polarion

Postby ValeV » Tue Sep 05, 2017 1:26 pm

Hi all,
I am having problems updating our company's Polarion 2015 to version 17.1.
1. I downloaded update from https://polarion.plm.automation.siemens.com/downloads/update.
2. I installed latest oracle java 8 to default location.
3. I ran file update.bat as administrator from downloaded folder. I get an error:

Code: Select all

Error: Registry key 'Software\JavaSoft\Java Runtime Environment'\CurrentVersion' has value '1.8', but '1.7' is required.
Error: could not find java.dll
Error: Could not find Java SE Runtime Environment.
Error: Registry key 'Software\JavaSoft\Java Runtime Environment'\CurrentVersion' has value '1.8', but '1.7' is required.
Error: could not find java.dll
Error: Could not find Java SE Runtime Environment.


I don't understand why it says it needs java 1.7.x, if it's written in Polarion's documentation that it uses java 1.8.x. I uninstalled 1.8 to go back to 1.7, but then I get an error that I need version 1.8. So it's an endless loop, which as a programmer, I dont like it. :D

Any help is greatly appreciated.

Return to “Polarion Application Lifecycle Management (ALM)”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests