Cannot change work item type due to required field

Description
lsimons
Posts: 8
Joined: Thu May 03, 2012 1:39 pm

Cannot change work item type due to required field

Postby lsimons » Thu May 03, 2012 1:53 pm

I have a set of generic Task work items that have code committed against them, but should have been handled by the life cycle of another work item type. I would like to "Change Type to..." the proper work item type. When I choose the work item, I receive the message:

Code: Select all

Work Item Link Rules are not checked during Type change.  Some custom field values might be converted during Type change.


The new type has a required field called "Version Identified" which is an enumeration to select the software version that the issue was originally discovered in. However, there is no red asterix next to the field in the editor, and when I mouse over the field, no drop-down appears. Other required fields do appear and allow me to select from the enumerated options. However, I cannot save because I cannot set the required field:

Code: Select all

Unknown server error:

javax.transaction.RollbackException: com.polarion.alm.tracker.internal.workflow.ValidatorWrapper$UserFriendlyWorkflowException: The required field 'ver_found' of Work Item 'msd56-1793' is missing!


I believe that ver_found is the internal name for the "Version Identified" field. Is there anything I can do to diagnose the issue and resolve it? We are running Polarion ALM 2011 (moving to 2012 shortly I believe).

Thanks,
Louis

jandlj
Posts: 20
Joined: Mon Aug 23, 2010 11:40 am
Location: Polarion Software, Prague
Contact:

Re: Cannot change work item type due to required field

Postby jandlj » Thu May 10, 2012 12:17 pm

Hi,
I found some issues in our tracker related to described use case and they were all solved in Polarion 2012. I have tried step by step what you did and I've not found any issues in Polarion 2012.
I suggest to update your Polarion to latest release to solve the problem.

lsimons
Posts: 8
Joined: Thu May 03, 2012 1:39 pm

Re: Cannot change work item type due to required field

Postby lsimons » Mon May 14, 2012 12:04 pm

Thanks for trying that out for me. I think we're planning the upgrade in the near future, so I'll talk to our Polarion administrator and try again after we upgrade.


Return to “Polarion Application Lifecycle Management (ALM)”

Who is online

Users browsing this forum: Ramonged, RidgeJelo and 16 guests