It's not possible to search for empty fields: foundInTestRun

Description
NAM
Posts: 1
Joined: Fri Jan 13, 2012 9:41 am

It's not possible to search for empty fields: foundInTestRun

Postby NAM » Fri Jan 13, 2012 9:57 am

Hello,

there's a problem, I don't know how to solve:

If I search for the Work Itme Defects with a self built query, in which the field "foundInTestRun" is empty, the result is that nothing was found. But there are a lot of Defects, in which this field is empty.

If I search for Defects, in which the field "assignee" is empty (assignee.id:######NULL), that works and shows me all the Defects.
Also the search for Defects with a specific content in the field "foundInTestRun" is possible (foundInTestRun:Funktionstest).
The only problem is to find Defects, in which this field is empty (foundInTestRun:######NULL).

Why does it not work? How can I find the Defects with the empty field "foundInTestRun"?

Kind regards,
Nicole

NickEntin
Posts: 472
Joined: Tue Oct 24, 2006 10:27 am
Location: Polarion Software GmbH, Stuttgart
Contact:

Re: It's not possible to search for empty fields: foundInTes

Postby NickEntin » Wed Jan 18, 2012 7:52 am

Hello Nicole,

answer to your question could be found if you use Query Builder for this purpose - see the first hint in "Custom Fields" section.
You need to type "#none" in the value of the field and when you build the query you see desired syntax.

For your case it would look like
ALL:ALL_VALUE AND NOT CUSTOM_FIELDS:foundInTestRun

Please note that foundInTestRun:######NULL will also work, but only for WorkItems, where the field value is set, but empty (i.e. it was edited and saved). For those workitems, where the field was never initialized this query won't work.

Best regards,
Nick


Return to “Polarion Application Lifecycle Management (ALM)”

Who is online

Users browsing this forum: No registered users and 9 guests