Not running most recent pre-save scripts after several commits

Description
drouleau
Posts: 5
Joined: Tue Mar 12, 2019 6:09 pm
Contact:

Not running most recent pre-save scripts after several commits

Postby drouleau » Wed Aug 07, 2019 5:18 pm

Hi,
I've uploaded new versions of my previously running pre-save scripts to make them more generic but I cannot run the latest uploaded versions. Polarion tries to run an interim version.

Here is the sequence of events:
- I committed version X of my scripts

- I discovered a problem (typo) in an #include statement (I was getting an error message on save
"The workitem is not saved because an file to include within a script could not be found: Script file to include 'CertProjectCommon.js' doesn't exist."
)


- I committed version Y of my scripts which fixed the module name I was trying to include. Specifically "certprojectcommon.js"

That didn't fix the error and I still get the previous error message even though the scripts are now trying to import the correctly-named module. And the module to be included does exist ;)

I checked the repository and the latest versions are indeed present.

What is wrong?

Do I have to clear some cache or poke something to get it to use the latest versions?

Any pointers?

Thanks in advance

Denis

Return to “Polarion Application Lifecycle Management (ALM)”

Who is online

Users browsing this forum: No registered users and 6 guests