ClearCase Import Problem

comand
Posts: 1
Joined: Mon Feb 27, 2006 5:22 pm

ClearCase Import Problem

Postby comand » Mon Feb 27, 2006 5:35 pm

Hi,

I'm attempting to convert a couple of projects that are contained in our ClearCase repository over to Subversion. When I run the import, I see cleartool returning useful information from lshistory, but there are many many errors of the form:

CCHistoryParser:96 ERROR - wrong revision: ...

In fact, it seems like none of the revisions are being imported at all:

CCProvider:84 INFO - ClearCase model has been created.
Model:84 INFO - Model summary:
Model:84 INFO - Total files in model: 0
Model:84 INFO - Total revisions in model: 0
Model:84 INFO - Total commits: 0
CCProvider:84 INFO - Svn model has been created
CCProvider:84 INFO - total number of revisions in svn model: 0
historyLogger:84 INFO - empty svn model - nothing to import
historyLogger:84 INFO - successfully finished
CCProvider:80 DEBUG - cleanup
historyLogger:84 INFO - duration: 353 seconds

Can anyone help out? I am running the import from a read-only view, and was intending to just create the dump file so I could take it to the SVN machine and import it manually. My configuration file is nearly identical (except for project path and svn import settings) to the ClearCase import sample config in the manual. I have tried both full and incremental import, and with/without trunk_only. I am really confused about the meaning of "wrong revision" -- there doesn't appear to be any reference to this error in the manual, and I (obviously) can't browse the code to see why the CCHistoryParser is breaking...

Any assistance would be greatly appreciated,
Cory.

spinck
Posts: 2
Joined: Sun Feb 26, 2006 7:57 pm

Clearcase to SVN : error #96

Postby spinck » Tue Feb 28, 2006 8:39 am

Hi,
I've got exactly the same problem that Cory has. For each file in the Clearcase project, command "cleartool lshistory ..." returns all the existing versions. I don't know what kind of operation is performed after lshistory, but the first version that is considered return error #96. None of the files seems to have a correct revision according to SVNImporter.

What does "wrong revision" means? What is the format of revision expected by SVNImporter?

Thanks a lot for any advice.

Stephane PINCK.

gwk
Posts: 7
Joined: Wed Mar 08, 2006 9:19 am
Location: Munich, Germany

me too...

Postby gwk » Wed Mar 08, 2006 9:29 am

I also get those error messages. I'm not sure if anything is working at all,
the repository is very large and the process is still running.

Q1: Does ClearCase import work for anyone at all?
If so, which version of svn-importer? I'm using 1.1M6, RedHat 9.0, JDK 1.5,
ClearCase version 2003.06.00.

Q2: Anyone from Polarion listening? Do you have a bug tracker where we might
enter this issue?

spinck
Posts: 2
Joined: Sun Feb 26, 2006 7:57 pm

In a hurry

Postby spinck » Wed Mar 08, 2006 7:44 pm

I'm wondering :evil: what the purpose of this forum is. No answer no advice. Just a balckhole for users problem.
Thanks!

gwk
Posts: 7
Joined: Wed Mar 08, 2006 9:19 am
Location: Munich, Germany

progress

Postby gwk » Thu Mar 09, 2006 7:59 am

Well I hacked away and got some progress (jad was my friend). The CC history parser was splitting
the version string on '\' instead of '/', which might succeed on Windows but
definitely not on Unix. Only partial progress so far, I am still getting
"CCHistoryParser:96 - wrong date:" a few times and then many many
"CCBranch:96 - can't find previous revision for deleted revision(skip): "
until it finally aborts with out of memory (I spent 256M already).

BTW the source is at http://community.polarion.org/polarion/ ... e=projects
for viewing (didn't find an svn URL yet), and it turns out my first problem was
already fixed in commit http://community.polarion.org/svnwebcli ... 6&crev=425
and another bug I ran into seems to have been handled in http://community.polarion.org/svnwebcli ... &crev=2540

It may be worthwhile to restart from the latest code version altogether.

Q: Hi Polarion would you care to let us know the SVN URL so we can pull down
the latest code?


Return to “Polarion SVN Importer (Repository Converter)”

Who is online

Users browsing this forum: No registered users and 5 guests